1.6에서 동작하는 어플인데 2.1에서 동작하게끔 수정하려고 합니다.
이 어플에는 어플과 jar 파일이 포함되어 있구요..

1.6 source에 새로 package를 만들어서 Android 2.1-update1로 변경했습니다.

에뮬에서는 1.6과 2.1에서 실행되지만, 실제 디바이스에 설치하려고 하면..

Installation error : INSTALL_FAILED_UPDATE_INCOMPATIBLE
Please check logcat output for more details.
Launch canceled!

라고 나옵니다. 그래서 logcat을 보니..
E      PackageManager       Package com.xxx.xxx signatures do not match the previously installed version; ignoring!
W     PackageManager       Package couldn't be installed in /data/app/com.xxx.xxx.apk
라고 표시됩니다.

어찌 하면 디바이스에 설치할 수 있을까요?