제가 옵티머스 Q 로 계속 어플리케이션을 개발하다가 얼마전에 2.1로 업그레이드 되서

2.1버전으로 이제 개발을 하게되는데요 1.6에서는 아무런 오류도 없이 잘돌아가던 어플리케이션이 갑자기...

 ERROR/AndroidRuntime(3580): java.lang.IllegalArgumentException: Receiver not registered: android.widget.ViewFlipper$1@30a82ad0

이런 오류가 나면서 한번씩 꺼짐니다. 오류나는 빈도 수는 그렇게 높지는 않습니다. 그래도 오류가 나서 찾아보니

안드로이드 2.1버전에서만 일어나는 오류라고 하면서 해결방법도 제시해주었습니다.

그 방법은 아래와 같은 방법 입니다.(제 소스코드에 있는 것)

 
@Override
public void onDetachedFromWindow() {
	try {
		super.onDetachedFromWindow();
	}catch (IllegalArgumentException e) {
		this.flipper.stopFlipping();
	}//end try/catch
}//end onDetachedFromWindow Method  



그래서 바로 제 소스코드에 적용했는데... 그래도 오류가 나는데... ㅠ.ㅠ;;;;;

누가 해결방법쫌 가리쳐주세요...ㅠ.ㅠ
11.JPG